Alfred workflow for J.D

That’s great - thank you!

Urgh!! I’m having the worst time with Alfred and J.D! it’s me! Human error. So first thing first, I’m a complete novice when it comes to Alfred workflow deployment. So what i think is my first problem firstly: When i when execute alfred-jd search naturally nothing returns. However, once i execute alfred-jd new, surely, an option or something should make itself available right? Nope.

I welcome any sage input or advice as to what I should do next. Also, I could share: this has been a two month ordeal i’ve been silently suffering thru. Ive given up on the low hanging fruit troubleshoot.

I’m so sorry that you’re having trouble with alfred-jd - it sounds really frustrating!

It sounds to me as if the workflow might not know where to look for your J.D root folder. Sorry if you have already tried this 20 times and it didn’t help, but can you check that you have configured the path to your J.D. folder in the workflow?

If you open Alfred’s preferences, select Workflows on the left hand side, then select Johnny.Decimal tools in the list of workflows. You need to click the [x] icon at the top (circled the in screenshot above).

That should get you something like the window above. The path outlined in red below is where my J.D folder is on my system. You need to click it and change the value to wherever your root J.D. folder is on your system. Then click Save and see if that works. You should be able to active Alfred, type ‘jd’ followed by a space, and then select from Areas, Categories or IDs which appear as options, then search within those once you have selected one.

If you are getting warnings about ‘unsigned binaries’, you might need to follow the instructions under ‘Install’ here.

I hope this helps! If it doesn’t let me know - perhaps you could show me equivalent screenshots to the ones here so I can see better what might be going on?

1 Like

Finally set this up on my new M1 MBA w/ Monterey. Works as indicated, no issues so far.

That’s great! You may be the first to use it on an M1.

Hello all! I am having a problem with this plugin and looking for help.

Storing system in iCloud Drive can't get path to be recognized · Issue #1 · bsagalfred-jd-Safari-08032022-0841

Hi @trijste!

I’m not entirely sure what’s going on here. At first I thought it might be the fact that the path has spaces in it, but I tested that by changing my JD folder to have spaces and it worked fine.

I think it might be something to do with the iCloud Drive folder. I tried creating a dummy skeleton JD system in mine and got the same issue. I haven’t done any development which uses iCloud Drive myself, but I think I remember seeing some discussion about the fact that it makes things a little tricky because the paths are not like standard file system paths.

Has anyone else got this working on iCloud Drive?

1 Like

Hi @bsag! Thanks for testing this. At least I know it’s the location and not anything else.

I posted the Alfred debugger information in my open GitHub issue.

I certainly appreciate your attention! If I didn’t have 2 TB of iCloud drive space, I would not seek to use it for this system.

I looked at the search.go code and wondered if this line is causing the issue:

func expandPath(path string) string {
	return strings.ReplaceAll(path, "~", os.Getenv("HOME"))
}

Because the iCloud drive path includes those “~” characters…

Ah, I think you may have hit on the possible problem! I won’t get time to dig into this before the weekend, but that gives me a good clue about what to try.

1 Like

Woohoo! Please keep me posted :grin:

Appreciate @bsag taking a look, but don’t forget you can always use Alfred’s built-in file search to open your stuff. That’s what I do.

I think I have the default settings which is just to invoke Alfred, press Space to enter ‘Open File…’ mode, and type the name of a folder or file. Just type your JD numbers there and the folder will pop right up.

2 Likes

You can indeed do that. My workflow just adds a thin layer of convenience on top really.

Anyway @trijste, I have fixed the bug now and released v0.3.3. It works for me with a dummy JD folder in iCloud Drive, but let me know if you have any problem with it. Thanks for reporting it!

1 Like

You did it! Fixed the problem for me. Thanks! Enjoying the process now of feeding my files and my mind into my J.D system.

I also noticed in Alfred that if you call it up and start typing your top level folder name (“File System” in my case, for lack of creativity), when it comes up you can hit command and down arrow and you will be right in your system at the top level. This is helpful in my case because I used a Symbolic Link to store all my work files both in my system (symbolically) but on my company OneDrive rather than my personal iCloud Drive.

1 Like

Yay! Glad it worked. That’s a useful tip about browsing the top level folder too.

BSAG! Thanks so much for taking the time to help; apologies for the belatedness of this response, life’s full of distractions. anywho-- I finally figured it out!

No problem! Glad you got it sorted out.